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Session Code: VAL04 

Product Line: Sage BusinessVision 

 

Presenter:   Edward Klapatiuk, Sage BusinessVision 

Description 

Sage BusinessVision v7.2 is here! Attending this session will ensure that you have the 
information needed to sell and support the new version of Sage BusinessVision. Join us 
as we take you through system requirements and the "nuts and bolts" of setting up the 
new product. Then explore the feature enhancements and discover how you can put 
this new functionality to work for your clients. With a lot of new enhancements, such as 
the ability to maintain and view unlimited years of General Ledger history, multiple units 
of measure, new system configuration options and more, you will not want to miss this 
opportunity to get "in the know".   
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Initial Installation and Configuration of v7.2 

Overview 

The installation of Sage BusinessVision v7.2 follows the same process as v7.1.  During 
the installation, you will be prompted to enter the Product ID/Serial number, and 
Activation code for each product or add-on that you are installing. 

 

  

 NOTE:  It is not necessary to reinstall CustomPack, e-BusinessVision, LAN Packs or Multiple Currency 
Manager if they have already been installed with v7.1.  The existing licenses will continue to be 
honoured. 

  

  

 FOR MORE INFORMATION:  For general information for clients upgrading from previous versions, 
refer to “Readme.rtf” which is located in the \Readme folder on the Sage BusinessVision CD. 

Data File Conversion 

Existing sets of Sage BusinessVision data will be converted to v7.2 format when logging 
in for the first time. 

 

  

 NOTE:  Once your data has been converted to be compatible with 7.2, it will no longer be compatible 

with prior versions. 

 

  

 NOTE:  During the file conversion to v7.2, unprocessed entries in the Auto-generate Purchase Orders 

function will be removed.  Please ensure that Purchase Orders are generated for all required entries 
prior to converting your data. 
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Files converted 

The following table lists data files that are converted, created, or reorganized during the 
v7.2 file conversion process. 

FILE NAME CONVERSION/NEW/REORGANIZATION 

addrs.btr Conversion – uppercase Ship-to ID’s 

ap.btr Reorganization – index maintenance 

ar.btr Reorganization – index maintenance 

billmtls.btr Conversion – support for multiple unit of measure 

bvcon.fil Conversion – support for new system settings 

country.btr Conversion – update country list 

customer.btr Reorganization – uppercase Ship-to ID’s 

custpric.btr Conversion – support for multiple unit of measure 

employee.btr Conversion – addition of new field  

hstaddrs.btr Conversion – uppercase Ship-to ID’s 

invent.btr Conversion – support for multiple unit of measure 

notes.btr Conversion – uppercase Ship-to ID’s 

ordaddrs.btr Conversion – uppercase Ship-to ID’s 

pchhistdtl.btr Conversion – support for multiple unit of measure 

prchordd.btr Conversion – support for multiple unit of measure 

pricing.btr New – support for multiple unit of measure 

receipts.btr Conversion – support for multiple unit of measure 

slshist.btr Conversion – support for order required date 

slshistdtl.btr Conversion – support for multiple unit of measure 

slsord.btr Conversion – support for order required date 

slsordd.btr Conversion – support for multiple unit of measure 

slstax.btr Reorganization – index maintenance 

uom.btr New – support for multiple unit of measure 

users.btr Conversion – support for new user settings 

userslog.btr New – support for user log 

userslv.btr Conversion – support for new user browse settings 

wbd_ship.btr Conversion – uppercase Ship-to ID’s 

wbm_ship.btr Conversion – uppercase Ship-to ID’s 

wbt_ship.btr Conversion – uppercase Ship-to ID’s 
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Using Existing Customized Reports 

If you are currently using Sage BusinessVision 7.2 and wish to re-use customized forms 
previously created for 7.1, they will need to be updated in order to be compatible with 
7.2.  If you do not use customized forms (i.e. you use the forms supplied with Sage 
BusinessVision) then you will not need to update your forms. The forms that require 
updating in order to be compatible with Sage BusinessVision 7.2 are: 

 Invoice – Order Entry 

 Invoice – Point of Sale 

 Order Confirmation 

 Packing Slip 

 Purchase Order 

 Quote 

For details on how to update existing customized forms, refer to 
“BV72_Customized_forms.pdf” which is located in the \Readme folder on the Sage 
BusinessVision CD, and in the \BusinessVision folder on any workstations with 7.2 
installed. 

System Setup Additions and Changes 

A number of changes and additions have been made to System Setup in order to 
activate and control some of the new features in version 7.2. 
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Company 

In File names, entries were added for “Unit of measure” and “Prices”. 
 

 
 

In Variable names, the entry for variable 4 is no longer in use. 
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General Ledger 

In G/L Setup, an entry was added for “Years of history to retain”. 
 

 

Customer 

In Customer setup, a check box was added for “Unique Ship-to ID’s”. 
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Inventory 

In Inventory Setup, a check box was added for “Default new items to non-physical”, and 
an entry was added for “Default unit of measure – Non-physical item”. 
 

 

Sales Order 

In Sales order setup, check boxes were added for “Convert quotes using next order no.” 
and “Prompt to confirm a zero freight amount”. 
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User Details Additions 

A number of additions have been made to User Details in order to activate and control 
new and existing features in version 7.2. 

Details 

The Application Background section was added to the Details tab. 
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Access – General Ledger 

In General Ledger > Options, entries were added for “Recurring journal entry”, “Copy 
G/L accounts wizard”, and “Browse G/L history”. 
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Access – Customer 

In Customer > Options, a new entry was added for “Move ship-to details”. 
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Access – Inventory 

In Inventory > Options, entries were added for “Add UOM”, “Modify UOM”, “Delete 
UOM”, and “Change default stock UOM”. 
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Access – Order Entry 

In Order Entry > Options, entries were added for “Prompt to override credit limit”, 
“Override credit limit supervisor”, “Override inventory returns flag”, “Prompt to create 
customer ship-to addresses “, and “Edit customer ship-to address details”. 
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Access – Utilities 

In Utilities, an entry was added for “Maintain User Log”. 
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Access – Purchase Analysis 

In Purchase Analysis > Options, an entry was added for “View historical cost prices”. 
 

 

Access – Point of Sale 

In Point of Sale > Options, entries were added for “Override inventory returns flag”, and 
“Default UOM entry status”. 
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Settings – Validate 

In Validate, an entry was added for “Account segments”. 
 

 
 

Settings – Miscellaneous 

In Miscellaneous, entries were added for “Add custom reports”, “Modify custom 
reports”, “Delete custom reports”, and “Autocomplete”. 
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Desktop Enhancements 

Application Background 

The application background can be customized by each user to display a different colour 
or image.  This feature can be accessed by selecting Options > Application Background 
from the menu.  This can also be performed from the User Details window using the 
Application background section of the Details tab. 
 

 

General Ledger Enhancements 

Integration Off Warning 

A warning message appears during logon when General Ledger integration is turned off 
in System Setup. 
 

 

Validate Account Segment Values 

Whenever a new account is created in the General Ledger module, the system can 
optionally check that all segment values entered by the user already exist in the 
segments file. 

If this option is set to Yes and the General Ledger uses only one segment, the system will 
automatically add any segments that do not already exist.  Also, when an account name 
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is changed, the system will automatically modify the description for the affected 
segment. 

If this option is set to Yes and the General Ledger uses more than one segment, the user 
will be prompted to add any segments that do not already exist. 

If this option is set to No, the user will not be prompted to add the new account to the 
segments file. 

Printing Journal Entries 

Journal entries that have not been posted can be printed using the print button in 
Journal Entry window. 
 

 
 

Journal entries that have been posted can be printed using the print button in Search 
and Reverse window. 
 

 
 

Import Depreciation Entries from Sage FAS 50 Fixed Assets 

Sage FAS 50 Asset Accounting is a fixed asset management system.  Starting with 
version 2008.1, it includes Sage BusinessVision in its list of supported accounting system 
links.  The link allows Sage FAS 50 to export general ledger entries for depreciation that 
can be imported into the Sage BusinessVision G/L. 
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To import FAS Fixed Asset files: 

Select File > Import > Sage FAS Import to display the FAS Import window.  

Enter or browse to the location of the FAS file, which must be in standard data format 
(an .sdf file extension).  

Click Import to start the process.  

Confirmation appears after the process is complete for both successful and unsuccessful 
imports. Click View log in the FAS Import window to see a list of problems encountered 
with a failed import attempt.  

Import G/L Chart of Accounts and Transactions 

The G/L Import Wizard allows you to import a chart of accounts or G/L transactions.  In 
either case, the Import Wizard can append to an existing file (add new records) but 
cannot modify records that already exist. 

The Import Wizard can be accessed from the File > Import menu.  Alternatively, the 
Chart of Accounts import can also be accessed during the Segment Setup stage of the 
New Company G/L Wizard.  This will allow you to import a chart of accounts into a set of 
data with no pre-existing accounts.  Once the import is complete, you can then proceed 
to define your special accounts from the list of imported accounts.   
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The Import Wizard allows to you define multiple import projects as templates that can 
be saved and then used when needed.  This is particularly useful for importing 
transactions repeatedly over time, such as for month end entries. 
 

 
 

The Import Wizard recognizes Comma Separated Value text files, as well as Microsoft 
Excel files as input. 
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During the mapping stage of the Wizard, fields from the file to be imported are 
displayed in the left list view, and available fields from the BusinessVision data are listed 
in the right list view.  BusinessVision fields that must be mapped are indicated as 
“Required field”. 
 

 
 

To map a field from the import file to a BusinessVision field, first select the import field.  
Then, select the destination field in the BusinessVision field list.  Finally, click the Map 
button.  When a field has been mapped successfully, it will appear in the bottom list 
view. 
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Once you have completed mapping all desired fields, click Import to proceed with the 
import.  

  

 NOTE:  If for any reason one or more records do not pass validation, the entire import will be halted 

without any changes being made to the BusinessVision data.  

 

  

 NOTE:  When G/L Integration is enabled, you will not be able to import transactions into any G/L 

accounts in the Accounts Payable and Accounts Receivable groups.   When G/L integration is disabled, 
transactions may be posted to accounts in any G/L group. 

 

  

 TIP:  When importing a CSV file that has a header record, select the “Skip the first record” option 

before clicking Import. 

 

Retain up to 99 Year of General Ledger History 

During the year-end process, general ledger transactions from last fiscal year can 
optionally be archived into G/L history files for later review and reporting.  To enable 
this option, set the number of years of history to retain prior to last fiscal year in the 
“Years of history to retain” field in System Setup. 

Once a fiscal year has been moved to history, no further transactions may be posted to 
that timeframe. 
 

  

 NOTE:  Once a fiscal year has been moved to history, no further transactions may be posted to that 

timeframe.  Additionally, Account Reconciliation and Multi-Company G/L Consolidation operate only 
on current files, not on history files. 
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G/L history can be viewed in several ways.  First, the History tab of General Ledger 
Account Details displays one entry for each year of history that is available for an 
account.  The list allows you to drill down to period by period summaries, to 
transactions, and to journal entries. 
 

 

The Historical Chart of Accounts Browse lets you view the entire chart of accounts with 
balances for the historical fiscal year chosen.  The browse allows you to drill down to 
period by period summaries, to transactions, and to journal entries.   To access this 
browse, select General Ledger > Browse G/L History from the menu. 
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When general ledger history prior to last fiscal year is present, the Find module allows 
you to specify the fiscal year that you want to find information in.  The first entry 
represents last, current and next fiscal years. 
 

 
 

When general ledger history prior to last fiscal year is present, the Reporting Suite 
allows you to specify the fiscal year that you want to run general ledger reports for.  The 
first entry represents last, current and next fiscal years. 
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Journal entries for transactions that are in general ledger history can be viewed from 
within Accounts Payable, Accounts Receivable, Employee Details, Job Cost, Purchase 
Analysis, and Sales Analysis. 
 

 

Customer Details Enhancements 

The enhancements made to the Customer Details module are centered around Ship-to 
addresses. 

Unique Ship-to ID’s 

A new System Setup option can be used to require that Ship-to ID’s are unique across all 
customers.  This new option is similar in behaviour to the requirement in versions prior 
to 7.0 that Ship-to ID’s be unique. 
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Move Ship-to ID to Customer 

In Customer Details, on the Ship to tab, there is a new utility that allows a Ship-to 
address to be moved to another customer.  The ability to use this utility is controlled by 
a User Details option. 
 

 

 

  

 NOTE:  Any existing invoices and open orders are unaffected when a Ship-to ID is moved from one 
customer to another.   Only future orders and invoices posted from them will be based on the new 
parent/child relationship.  
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Use Bill-to Specific Prices 

In Customer Details, on the Ship to tab, on the Taxes and Shipping tab, there is a new 
option that controls the source of customer specific prices for each Ship-to address.  If 
the new option is enabled, the parent customer’s specific prices will be applied to 
orders created for this ship-to address.  If this option is disabled, you will be able to 
enter customer specific prices against this ship-to address. 
 

 

Inventory Enhancements 

Allow Back Orders and Allow Returns 

In Inventory Details, on the Info tab, two new options have been added.  The “Allow 
back orders” setting controls whether or not an item can be back ordered in Order 
Entry.  This option cannot be overridden.   
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The “Allow returns” setting controls whether or not an item can be returned in Order 
Entry or Point of Sale.  This “Allow returns” setting is affected by two options in User 
Details.  Depending on the user’s “Allow returns” and “Override inventory returns flag” 
options, the user may or may not be able to process returns, and may be prompted to 
override the inventory setting. 
 

 
 

Non-Physical Inventory Items 

A non-physical inventory item is one that can not be warehoused and shipped like 
regular, tangible items.  A service that is provided for an hourly cost can be considered a 
non-physical inventory item.  Unlike normal inventory items, quantities for non-physical 
items are not tracked in the Inventory module.  Additionally, the “Serialized” and “Allow 
back orders” flags cannot be set for non-physical inventory items. 

The differences between a normal item and a non-physical item are: 

 Quantities are not tracked for non-physical items 

 Non-physical items can be assigned standard costs, rather than current or 
average costs 

 Serialization cannot be enabled for non-physical items 

 Non-physical items cannot be received using the “Receive Inventory” function 

 Non-physical items cannot be transferred between warehouses using the 
“Warehouse Transfer” function 

 Non-physical items are ignored by the “Physical Inventory” utility 

 Non-physical items are ignored by stock status reports 

All other attributes are shared between regular inventory items and non-physical items. 
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When creating a new item in the inventory module, press Ctrl + H to specify it is a non-
physical item. The system will change or hide fields that only apply to physical items. 
You can use System Setup to default all new inventory items to non-physical, and to 
define the default unit of measure for new non-physical inventory items. 

Multiple Units of Measure 

Multiple units of measure can be assigned to each inventory item.  Unit of measure 
codes and quantity factors are defined at the item level, which means that several items 
may use the same unit of measure code, which have different attributes.  (i.e. a BOX of 
golf balls may have 6 EACH’s, while a BOX of socks may contain 10 PAIR’s). 

When creating a new inventory item, the stock unit of measure should be established.  
Note that once the item is saved, the unit of measure code cannot be modified. 

Each item has a stock, default buy, and default sell unit of measure.  
 

 

 

  

 NOTE:  The Inventory Details module stores quantities ONLY in stock unit of measure.  Any inventory 

transaction processed using a different unit of measure is converted to stock unit of measure.  
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Units of measure have the following important attributes: 

Quantity factor – used to determine the relationship between the current unit of 
measure and the stock unit of measure.  This factor could be stated in a direct or 
indirect manner.  (i.e. “2 HALF per EACH”, or “0.5 EACH per HALF”) 

Buy unit of measure – whether or not this unit of measure should be available 
for use in the Purchase Order module 

Sell unit of measure – whether or not this unit of measure should be available for 
use in the Order Entry and Point of Sale modules 

Allow fractional quantities in orders – whether or not this unit of measure should 
allow entry of decimal quantities in Order Entry, Point of Sale, and Purchase 
Order 

UPC code – UPC codes have been moved from the item level, to the unit of 
measure level.  Therefore more than one UPC code can be used with each item. 
 

  

 NOTE:  Changing the quantity factor may cause unexpected results when open orders for that 

item/unit of measure exist.  Any open orders should be reviewed after changing a quantity factor. 

 
Due to the fact that UPC codes have been moved to the unit of measure from the item, 
UPC codes are no longer a navigation key.  In order to find an item quickly by UPC code, 
use the UPC code mini-browser, which can be accessed via the UPC button in the 
Inventory Details toolbar.  
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Pricing information is no longer attached directly to the inventory item, but instead is 
now attached to the unit of measure.  Each unit of measure has its own list of twenty 
selling prices, quantity breaks, and promotional price that is independent of the prices 
of other units of measure. 

As an alternative to entering prices for each unit of measure, a price factor can be used.  
When the “Use price factor” check box is checked for a unit of measure, its price will be 
based on the price for the stock unit of measure, multiplied by the price factor entered.  
In the example below, once DOZEN will be sold for 12 times the price of an EACH. 
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Customer Specific Prices and Vendor Specific prices are also established at the unit of 
measure level. 
 

 
 

The default stock, buy and sell unit of measure can be reassigned using the buttons on 
the Unit of Measure tab toolbar in Inventory Details.  For example, in order to change 
the default buy unit of measure, select a UOM code that has “Buy unit of measure” 
enabled, and then click the “Set default buy unit of measure button”. 
 

 

 

  

 NOTE:  The stock unit of measure can only be changed when the on-hand quantity is zero.  If the 

stock unit of measure is changed, the quantity factors and prices of all units of measure for the item 
should be reviewed, as well as any open purchase orders and sales orders. 
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The Receive Inventory function allows you to specify the unit of measure in which the 
receipt is being made.  Note that the backorder, on-hand, committed and available 
quantities are displayed in stock unit of measure only, just as they are on the Details tab 
of Inventory Details. 
 

 
 

The Warehouse Transfer function allows you to specify the unit of measure in which the 
transfer is being made.  Note that the backorder, on-hand, committed and available 
quantities are displayed in stock unit of measure only, just as they are on the Details tab 
of Inventory Details. 
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Purchase Order Details allows entry of any valid unit of measure that has the “Buy unit 
of measure” setting enabled.  Unit prices are based on either the vendor specific price 
for that item/unit of measure or are calculated based on the quantity factor and the 
current cost of the item in stock unit of measure.  Purchase Analysis reports display the 
selected buy unit of measure. 
 

 

 

When Receipts records get created by the Receive Inventory function, the Warehouse 
Transfer function, or the Purchase Order Details module, the quantities received are 
recorded in both stock unit of measure and receipt unit of measure. 
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Receipts reports can be run for either stock unit of measure, or receipt unit of measure.  
Other inventory reports are run for stock unit of measure. 
 

 
 

Bill of Materials support the units of measure established in inventory, and also the 
units of measure established within Bill of Materials itself.  When entering a line on a bill 
of materials, if an unrecognized unit of measure is entered, you will be able to establish 
the conversion factor and usage quantities as in previous versions. 
 

 
 

When entering a line on a bill of materials, if a unit of measure is entered that has 
already been established for that item in inventory, you will be able to establish the 
usage quantities , but the conversion factor will be drawn from inventory. 
 

 

  

 NOTE:  If a line item on a bill of materials uses a unit of measure whose conversion factor is drawn 

from inventory, future changes to the quantity factor in inventory will NOT be reflected on the bill of 
materials.  
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Order Entry allows entry of any valid unit of measure that has the “Sell unit of measure” 
setting enabled.  Sales Analysis reports display the selected sell unit of measure. 
 

 

 
The Alternates browse in Order Entry displays all available units of measure for an 
alternate item.  The available quantities listed in the browse have been calculated based 
on the actual available quantity in inventory, which is stated in stock unit of measure. 
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Point of sale allows entry of any valid unit of measure that has the “Sell unit of measure” 
setting enabled.  “F12” is used as a hotkey to enable/disable entry in the Sell UOM field. 
 

 
 

The standard Import utility allows units of measure to be imported for existing items. 
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The standard Export utility includes unit of measure information in the Inventory export.  
Unit of measure information is found on the “Inventory_Dtl” tab in Excel, or in 
“Inventory_dtl.txt” when exported to a text format. 
 

 
 

E-BusinessVision uploads only the stock unit of measure far any inventory item.  An item 
may have a default sell unit of measure that differs from its stock unit of measure.  In 
that case, the unit of measure uploaded to the web store is the stock unit of measure as 
long as it is flagged as a sell unit of measure.  If the stock unit of measure is not flagged 
as a sell unit of measure, then the inventory item will not be uploaded to the web store. 

External orders created in Sage BusinessVision and uploaded to the web store may 
contain units of measure other than the stock unit of measure. If the external order is 
then added to the shopping cart on the web store the item will be ordered and 
processed in the unit of measure of the web store. 
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Order Entry Enhancements 

Prompt to Create Customer Ship-To Addresses 

Whenever a new ship to address is created in Order Entry, the system can optionally 
prompt the user to add the ship-to address to the customer file.  This option is 
controlled by the “Prompt to create customer ship-to addresses” setting in User Details. 

 

Edit Customer Ship-To Address Details 

The address fields on the Ship-To tab in Order Entry can optionally be open for input 
even when a ship-to address has been selected from the customer file.  This option is 
controlled by the “Edit customer ship-to address details” setting in User Details. 

Required Date 

Orders now have a “Required Date” field.  This label for this field is underlined, which 
indicates that it can be used as a sort key to navigate through the order file.  The 
required date has been added to existing reports.  Also, “Order List – Detailed – By 
Required Date” and “Order List – Summary – By Required Date” have been added to the 
Report Suite.  
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Confirm Orders with Zero Freight Charges 

Whenever an order is created in Order Entry, the system can optionally prompt if the 
freight amount for the order is zero.  This option is controlled by the “Prompt to confirm 
a zero freight amount” setting in System Setup. 

 

  

 NOTE:  This option only applies to shipping methods that use the “Prompt” calculation method.  It 

does not apply to shipping methods that use the “Fixed” or “Rate” calculation methods.  

Quotes Converted to Orders use Next Order Number 

Whenever a quote is converted to an order in Order Entry, the system can optionally 
use the next available order number, rather than retaining the original quote number.  
This option is controlled by the “Convert quotes using next order no.” setting in System 
Setup.  When this option is enabled, the original quote number is still retained on the 
order, can be viewed on the Order Details tab in Order Entry, and can be used in search 
criteria in Find and Sales Analysis. 

 

Credit Hold Override 

When an Order Entry user encounters an order for a customer who has a credit 
problem, the system can now optionally allow a supervisor to override the credit hold so 
that the order can be invoiced.  Users who should be prompted to allow a supervisor to 
override the credit hold must have the “Hold invoicing” option  in User Details set to 
“Over limit”, and the “Prompt to override credit limit” option set to “Yes”.  Users who 
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are supervisors capable of overriding a credit hold must have the “Override credit limit 
supervisor” option in User Details set to “Yes”. 

 

 

Purchase Order Enhancements 

Update Vendor Cost based on Purchase Order Receipt 

Whenever an item is received on a Purchase Order, the system can optionally update 
the vendor specific cost for that item.  This option is controlled by the “Update cost 
price at time of receipt” setting in Vendor Specific Pricing and is set on each specific 
price independently. 
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Purchase Order Type 

Purchase Orders can be printed and e-mailed (Form and e-mail), e-mailed only (E-mail) 
or printed only (Form).  This option is defined at the vendor level, using the “Purchase 
Order Type” list on the Details tab of Vendor Details. 

 

Point of Sale Enhancements 

Enter Customer Number 

The Customer Details dialog allows entry of the customer number when the “Enter 
Customer No.” check box is checked. 

 


